Workpuls is currently compatible with Windows and macOS supported devices, so it can run on all Windows versions from Win 7 and newer.

Since Windows 7 is no longer being supported by their developer - Microsoft, some of Workpuls users that have this version of Windows might need to take one extra step in order to run Workpuls on their computers.

If you Install and run Workpuls and software does not start, or you encounter any other issue upon startup or installation process, you should do the following:

Note: As dotnet 4.0 reached end of life and is no longer supported, similarly to how Windows 7 is no longer supported by Microsoft, some users might be experiencing difficulties with installing / updating to version 4.0. If you are among them please find links to other versions on the bottom of the web page linked above and try with dotnet version 4.5 instead.

Did this answer your question?